News

Due to heavy spamming attempts on this forum, automatic registration has been disabled. We will approve registration requests as quickly as possible (unless you're a spammer of course :) )

Topic: Loaded GIF/PNG image transparency not working?  (Read 477 times)

0 Members and 1 Guest are viewing this topic.

Offline TrainzLuvr

  • Full Member
  • ***
  • Posts: 117
Loaded GIF/PNG image transparency not working?
« on: September 30, 2018, 11:25:41 pm »
Hi,

I have a rectangle, and I'm trying to Load an image with no background (transparency) onto it. AnyRail either does not consider the supplied image transparency in case of a GIF and makes the background white/opaque; or with PNG-8, sometimes it makes the background gray, and other times the entire rectangle is black and you can't see anything.

EDIT: Selecting a matte colour during GIF export makes the background that colour in AnyRail, or black if no matte colour is selected.

Thanks.
« Last Edit: September 30, 2018, 11:35:15 pm by TrainzLuvr »

Offline TrainzLuvr

  • Full Member
  • ***
  • Posts: 117
Re: Loaded GIF/PNG image transparency not working?
« Reply #1 on: October 01, 2018, 11:49:19 pm »
So, I tried downloading transparent GIFs from the web and the same thing happens - the background colour varies, but it is not see-thru. I suppose a regression in AnyRail happened a some point of time, not sure when.

Offline TrainzLuvr

  • Full Member
  • ***
  • Posts: 117
Re: Loaded GIF/PNG image transparency not working?
« Reply #2 on: October 04, 2018, 11:53:26 pm »
Could anyone else please try adding a transparent image to a rectangle, and let me know if it works for them?

Perhaps I'm doing something wrong...

Offline poppy2201

  • Full Member
  • ***
  • Posts: 181
    • Northwest Florida T-TRAK-Z
Re: Loaded GIF/PNG image transparency not working?
« Reply #3 on: October 05, 2018, 08:21:21 am »
Here's mine.  This is a transparent .png image file.
« Last Edit: October 05, 2018, 08:24:27 am by poppy2201 »

Offline TrainzLuvr

  • Full Member
  • ***
  • Posts: 117
Re: Loaded GIF/PNG image transparency not working?
« Reply #4 on: October 06, 2018, 04:58:15 am »
Thank you!!

Clearly I was doing something wrong by selecting Export As PNG-8 in Photoshop.

Instead, I did Save As, selected PNG, and it works as intended, hum...