• Welcome to AnyRail Model Railroad Forum. Please login or sign up.
 
September 18, 2021, 04:00:46 pm

News:

Due to heavy spamming attempts on this forum, automatic registration has been disabled. We will approve registration requests as quickly as possible (unless you're a spammer of course :) )


Version 6.22

Started by David, January 21, 2019, 05:03:13 pm

Previous topic - Next topic

David

Hi all!

Version 6.22 is a bit Märklin related.

We added the 'Start up' track, which is really the same as C track.
We also added the long awaited turntable for C track.

Also, we added Czech language support!

Some minor tweaks have been done to the 3D generation so that it is both faster and uses less memory.
This means that some of the plans that were too large at first will just stay below the maximum memory usage threshold and are displayed properly now.
When we upgrade AnyRail to be a 64-bit application, this problem will be gone entirely.

Have fun!

David.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

Augie

January 23, 2019, 09:44:53 pm #1 Last Edit: February 07, 2019, 10:07:50 pm by David
Hello David:

Just looking through the blog reading about the updates. Then I thought, well I have never looked at my plan in 3D.
So I tried it. It seems I am not only an excellent pretend track designer, i'm damn good in 3D ::)

David

David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

Future-Digital

Thank you for moving it, David

Bill
"I find television very educating. Every time somebody turns on the set, I go into the other room and read a book." - Groucho Marx

BigBlueJim

Hi David... I believe we need a new install script for V6.22 for the Crossover product. I tried to run the update and it failed. I believe it is looking for the new executables in the V6.22 package.
Thanks
Jim

David

@Jim: We only support native Windows, not Crossover or other emulators based on Wine. They're just to far behind on emulating Windows, and we don't have the equipment or the time to investigate Linux/Mac compatibility.
You might want to try and install the program on a Windows computer and then copy the AnyRail6 directory to Crossover/Wine.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

BigBlueJim

Thanks David,
If I install a VM on my MAC (Parallels Desktop 14 for Mac) which version if windows do you suggest  for running AnyRail V6.22?

Jim...

David

@Jim: I would suggest Windows 10, but otherwise, at least Vista.
From the future version 7 of AnyRail, we will drop Vista support.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

BigBlueJim

Thanks David. I installed Win 10 under Parallels/MAC and AnyRail is working great

Jim