• Welcome to AnyRail Model Railroad Forum. Please login or sign up.
 
December 05, 2019, 06:12:25 pm

News:

Due to heavy spamming attempts on this forum, automatic registration has been disabled. We will approve registration requests as quickly as possible (unless you're a spammer of course :) )


Version 6.26

Started by David, December 01, 2019, 04:29:55 pm

Previous topic - Next topic

David

December 01, 2019, 04:29:55 pm Last Edit: December 02, 2019, 06:08:24 pm by David
Hi all!

This version has the following quite exotic new track libraries:
- Ypsilon, an I gauge tin train system from Germany, 1920.
- Marx, an O gauge track system much like Lionel O27 gauge but with an O34 curve.

The following libraries received updates:
- N Peco Finescale code 100
- HO Marklin K & C
- Scalextric
- O MTH RealTrax
- The symbol libraries

Furthermore:
- AnyRail now saves your last scroll position in the plan file.
- A misleading error message when trying to print when no printers are installed is improved.
- The list of sections now displays the lengths with the correct accuracy.
- A problem in the 3D view with holes in the train table is fixed.
- A problem in the 3D view with drawing pillars is fixed.

Enjoy!


David.

6.26.1 Fixes an issue that the plan file is always flagged as 'changed'.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

Sven

Thanks David. 
Could you please provide some details in what was changed for the Märklin K library? And do these changes automatically change any existing layouts which use tracks from K that were now modified? Thanks.

David

@Sven: for the Marklin K library there was a very small change. One piece was not allowed to flip (7287), which made it sometimes impossible to flip (part of) a layout.

A library update will usually not affect your track plan.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

Tom Springer

David,

It appears V6.26.0 wants to save a layout even if the user did nothing to it.  Open 6.26, then immediately try to quit AR and it asks to save the 'empty' default layout.

Is this because of the change to save the last scroll position?
Tom Springer

(Unintentional Pyromaniac)

Peter Buyk

Quote from: Tom Springer on December 02, 2019, 12:51:07 amDavid,

It appears V6.26.0 wants to save a layout even if the user did nothing to it.  Open 6.26, then immediately try to quit AR and it asks to save the 'empty' default layout.

Is this because of the change to save the last scroll position?

I think it is a bug same thing happens here to

poppy2201

Quote from: Peter Buyk on December 02, 2019, 08:32:57 am
Quote from: Tom Springer on December 02, 2019, 12:51:07 amDavid,

It appears V6.26.0 wants to save a layout even if the user did nothing to it.  Open 6.26, then immediately try to quit AR and it asks to save the 'empty' default layout.

Is this because of the change to save the last scroll position?

I think it is a bug same thing happens here to

Ditto.
Charles J.

David

Understood! 6.26.1 should fix this.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

Nick the Nomad

Surely that's going to happen as soon as you change the view of the layout, if we now have the facility to save the last view?

Nick the Nomad
Just getting ready for tonight's trip home on the Spirit of Tasmania

TodaProduction

David,

I installed 6.26.1. The version display has also changed to 6.26.1.
However, the AnyRail installer says "Some updates failed" and shows me the AnyRail update file again.
As a precaution, I temporarily turned off the virus detection software, then uninstalled and reinstalled it, but the situation remains the same.

Tom Springer

Same here.  First attempt was via Automatic Update.  Then tried downloading the MSI file in case anything was different; appears nothing was different.

Install wanted to close the open AnyRail session, but couldn't.  hmmm...

After 'failure to install correctly' msg, the process opened 6.26.1  hmmm...

Then tried the check for updates manually, 6.26.1 found 6.26.1 'available' but when the process tried to install (itself?) got the Modify/Repair/Remove options choice.
Tom Springer

(Unintentional Pyromaniac)

David

I'll look into it. It seems to be a problem in the installer software we use.
However, the software is properly installed.

Trying to install an already installed program always results in Modify/Repair/Remove.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

Tom Springer

David,

Thank you.  Guessed the Modify/Repair meant that the install was probably good.  Just wanted to document what I saw in case it helped.
Tom Springer

(Unintentional Pyromaniac)

David

Thanks to all. The warning should no longer appear.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

TodaProduction

David,

Thank you. I understood that AnyRail itself was installed correctly.
I also confirmed that you changed the server settings for the update program.
However, "FILE -> Help -> Check for updates" reports to me again that there is a new version 6.26.1.
If I continue with the download and installation, a more serious message will be displayed :-).
There still seems to be a problem comparing the old and new programs.

David

@Toda: could you please uninstall AnyRail, then download a fresh copy, and install that?

The problem is that the installer wrote its version in the wrong place in registry.
The new one does it correctly.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.