News:

Due to heavy spamming attempts on this forum, automatic registration has been disabled. We will approve registration requests as quickly as possible (unless you're a spammer of course :) )

Main Menu

Import Anyrail into JMRI

Started by RCMan, May 14, 2022, 02:17:58 PM

Previous topic - Next topic

RCMan

I do not know if this is n AnyRail issue or JMRI.

I made an exact track plan of my very old N-Scale layout. This layout was made around 1995. It uses Atlas fixed and flex track.

The AnyRail dimensions where kept exactly the size of the layout (80x 32 inches).

Exported the file to an XML file for import into JMRI.

Imported into JMRI and worked fine except there is a lot of extra blank area around the layout.
I do not see a way to eliminate the extra area so the Layout fits the screen correctly without scroll bars to keep it correctly aligned.

Any suggestions?

Dennis
Dennis<br />Bonham Texas

David

You set the work area in AnyRail to 80 x 32?
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

RCMan

Yes, no extra area around the layout.

Dennis
Dennis<br />Bonham Texas

David

Could you please post the AnyRail file here for us to try?
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

RCMan

Here is my file.
Dennis<br />Bonham Texas

David

In JMRI PanelPro you can open the Zoom menu and select 'Zoom to fit'.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

RCMan

I did what you said, but that does not work.

What I found out is there are 2 Construction lines that extend downwards and JMRI thinks these are part of the layout.

If I turn off the Construction lines view in JMRI nothing happens, but If I delete the 2 pieces of track with the construction lines and do the Zoom to Fit, that works.
Dennis<br />Bonham Texas

David

I'm not sure what happens in Panel Pro. It creates an unnecessary scroll bar when I click 'Zoom to fit', but it fits the complete plan (see the JMRI screendump below).
In the XML file, you can see the size is 4644 x 1858. The background image is 1280x512.

I'm not really sure what you mean by a construction line.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

RCMan

I captured the problem.

There are three captures.
1. ZTOFIT with Construction Lines
2. ZTOFIT Construction Lines turned OFF in JMRI
3. ZTOFIT 2 Construction Lines and track sections Deleted.
Dennis<br />Bonham Texas

David

The construction lines are a JMRI feature. In AnyRail, there's a similar feature named 'Guides', but that's not used here.
Clearly we don't have much influence on how JMRI works.

However, what I see is that you don't have the background image. This is exported along with the XML file. When you open the panel, is there a message that JMRI can't find the image? If so, please make sure that in PanelPro, under Preferences/File Locations, the 'User Files Location' is where both your XML and the JPG file are.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.

RCMan

No message about the background image.

Do I need that also? What does it give me?

The Track import works fine and have all the turnouts, blocks, senors and Block Content ID's.
Started on the Signals now.

Will contact JMRI to see if they want to do anything about this. Finger not crossed.

Dennis
Dennis<br />Bonham Texas

David

The background image is just a screenshot of the plan in AnyRail. So it contains possible scenery items, but also the ruler as you can see in the picture I posted earlier.
David Hoogvorst. Founder and Owner of DRail Software. Creator of AnyRail.